OpenTofu registry is incorrectly rate limiting some users
Resolved
Aug 13 at 01:41pm BST
We have taken steps to disable the rate limiting rule that was mistakenly firing and we are hearing reports that this issue is now resolved.
We have opened a ticket with cloudflare to investigate further about why this rate limiting request was being fired, we will provide an update when we have more information.
Affected services
Updated
Aug 13 at 01:05pm BST
We've received more reports of this and are continuing to investigate.
Affected services
Updated
Aug 13 at 12:32pm BST
This issue should now have been resolved.
If users continue to hit this issue we encourage you to comment on the github issue here: https://github.com/opentofu/registry/issues/2614 or reach out to the OpenTofu team on slack.
Affected services
Created
Aug 13 at 11:35am BST
We've identified an issue where the OpenTofu Registry may be incorrectly rate limiting some users.
This manifests as an error stating "host registry.opentofu.org requires authentication credentials" when downloading providers when using OpenTofu.
Related issue: https://github.com/opentofu/registry/issues/2614
Affected services